PlatformIdFuji -> PlatformIdRcd?
Does this come from a string in a system binary somewhere, or is it merely what we're calling it? If the latter, I think "PlatformIdRcd" fits better. The rationale being that Fuji appears to be the codename of the mklive kart/firmware, while "rcd" seems to be the part of the Switch SDK - albeit not (yet) part of sdknso - which handles communication with remote controlled devices which are paired via LP2P link. And I would bet that there's an rcd device-side component as well. If this is a general-purpose framework (which "Fuji" is merely the first released product to leverage) then it would make sense for that to be what gets special treatment by the LDN sysmodule.
That's a very good point. The string "PlatformIdFuji" is official, it was found in a leftover dev title (can't remember which one but I believe it was a version of DevMenuCommand) around the time service "ndd" was added (and later removed) to "ldn" by mistake. However, this was way before mklive was released. I only came to learn about the "rcd" namespace from mklive strings and my best guess is that "rcd" is indeed an umbrella namespace for the framework itself. "Fuji" was most likely a pre-release codename and might have been deprecated since, but no new strings/symbols have surfaced again so it's difficult to tell for sure.